网络通信 频道

IPv6 over an IPv4 Tunnel over MPLS

这个方法是在《Deploy IPv6 Network》中看到的,有个问题,当2个CE都是在as 10中的话,那么因为bgp的soo特性路由是不能正常被加入bgp路由表的。在ipv4中可以通过as-override来解决,但是ipv6中根本没这个参数,暂时还不知道如何解决。
R1

hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ipv6 address FC00:1::1/128
ipv6 enable
!
interface Ethernet1/2
no ip address
duplex full
ipv6 address FC00:12::1/32
ipv6 enable
!
router bgp 10
no synchronization
bgp log-neighbor-changes
neighbor FC00:12::2 remote-as 100
neighbor FC00:12::2 update-source Ethernet1/2
no auto-summary
!
address-family ipv6
neighbor FC00:12::2 activate
network FC00:1::1/128
exit-address-family

R2
hostname R2
!
ip cef
!
ipv6 unicast-routing
mpls label protocol ldp
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel0
no ip address
ipv6 address FC00:24::2/32
ipv6 enable
tunnel source 2.2.2.2
tunnel destination 4.4.4.4
tunnel mode ipv6ip
!
interface Ethernet1/1
no ip address
duplex full
ipv6 address FC00:12::2/32
ipv6 enable
!
interface Ethernet1/3
ip address 192.168.23.2 255.255.255.0
duplex full
mpls ip
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.0.0 0.0.255.255 area 0
!
router bgp 100
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
neighbor FC00:12::1 remote-as 10
neighbor FC00:12::1 update-source Ethernet1/1
neighbor FC00:24::4 remote-as 100
neighbor FC00:24::4 update-source Tunnel0
!
address-family ipv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
no neighbor FC00:12::1 activate
no neighbor FC00:24::4 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv6
neighbor FC00:12::1 activate
neighbor FC00:12::1 default-originate
neighbor FC00:24::4 activate
exit-address-family
!
ipv6 route ::/0 Tunnel0
!
mpls ldp router-id Loopback0
 
 
0
相关文章